[OpenAM] Apache 2.2 web agent for RHEL 5 x86_64?

eldapo eldapo at lembobrothers.com
Mon Apr 2 15:42:47 BST 2012


Yes, our test box has been yummed up to the latest versions of
everything (we've also tried this on several other machines). For apr
that is 1.2.7-11.el5_6.5, built 20 May 2011.

Here's my nm output:

[root at test httpd]# nm -D /usr/lib64/libapr-1.so.0 | grep
apr_pool_pre_cleanup_register
0000000000016b50 T apr_pool_pre_cleanup_register

Unfortunately it looks like even the latest version of the web agent
is specifically looking for apr 1.3.0 or newer, which Red Hat does
not/will never provide for RHEL 5.  Patching only rather than
upgrading is part of their whole long term support philosophy -- and
the reason we run it in our data center.

 Here's my error_log on starting up httpd:

[Mon Apr 02 10:11:16 2012] [notice] Apache/2.2.3 (Red Hat) configured
-- resuming normal operations
[Mon Apr 02 10:11:19 2012] [notice] caught SIGTERM, shutting down
[Mon Apr 02 10:24:25 2012] [notice] suEXEC mechanism enabled (wrapper:
/usr/sbin/suexec)
[Mon Apr 02 10:24:25 2012] [crit] Policy web agent initialization
failed (need APR library version 1.3.0 or newer)
Configuration Failed

Of course this all works fine on RHEL 6 (apr-1.3.9-4.el6_1.2), but
upgrading the number of servers we've got in our data center from 5 to
6 would not be a trivial task -- even if I could get approval.



More information about the OpenAM mailing list